注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Tenhlf的博客

 
 
 

日志

 
 

GRE的主要作用与配置  

2010-08-27 17:45:46|  分类: 路由器、防火墙 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

GRE的主要作用是什么?


通用路由封装(GRE)最初由Cisco开发,现在是一个RFC 1701、RFC 1702和RFC 2784定义的标准。GRE是一个在网络之间传输数据包的通道协议。

  如果对你而言它听起来像一个虚拟专用网络(VPN),这是因为理论上确实是这样:技术上,GRE是一种VPN,但它并不是一种安全的通道方法。不过,你可以用IPSec这样的加密方法对GRE进行加密,构建一个安全的VPN。

  实际上,点对点通道协议(PPTP)就使用GRE来建立VPN通道。例如,如果你应用微软VPN通道,在默认情况下,你使用PPTP,它使用GRE。

  我为什么要使用GRE?

  下面列出了一些使用GRE为流量建立通道的原因:

  你需要加密多点传送流量。GRE通道能够传送多点传送数据包——就像真实的网络接口一样——这与使用IPSec不同,它不能加密多点传送流量。OSPF、EIGRP和RIPV2都属于多点传送。而且,许多视频、VoIP和音乐流应用程序都使用多点传送。
  你只有一个不能路由的协议,如NetBIOS或非IP网络上的非IP流量。例如,你可以通过一个IP网络使用GRE为IPX或AppleTalk建立通道。
  你需要用不同的IP地址连接两个由一个不同网络连接的相似网络。
  我如何配置GRE通道?

  在Cisco路由器上配置GRE通道相当容易——只需要执行几条简单的命令即可。下面是一个简单的配置实例:

  路由器A:

  interface Ethernet0/1

  ip address 10.2.2.1 255.255.255.0

  interface Serial0/0

  ip address 192.168.4.1 255.255.255.0

  interface Tunnel0

  ip address 1.1.1.2 255.255.255.0

  tunnel source Serial0/0

  tunnel destination 192.168.4.2

  路由器B:

  interface FastEthernet0/1

  ip address 10.1.1.1 255.255.255.0

  interface Serial0/0

  ip address 192.168.4.2 255.255.255.0

  interface Tunnel0

  ip address 1.1.1.1 255.255.255.0

  tunnel source Serial0/0

  tunnel destination 192.168.4.1

  在这个例子中,两个路由器各有一个虚拟接口——通道接口。这个接口像一个点对点T1电路一样,有它自己的网络。经过通道网络的流量也流经串行网络。

  对每个路由器而言,很明显它们有两条远程路径——串行接口和通道接口(流经通道)。然后这个通道就能传送非路由流量,如NetBIOS或AppleTalk。如果它通过互联网,你可以使用IPSec进行加密。

  如下面的输出所见,路由器B上的通道接口和其它接口一样:

  RouterB# sh ip int brie

  InterfaceIP-AddressOK?MethodStatusProtocol

  Ethernet010.1.1.1YESmanualupdown

  Serial0192.168.4.2YESmanualupup

  Serial1unassignedYESunsetadministratively downdown

  Tunnel01.1.1.1YESmanual upup

  RouterB#

  GRE通道故障修复

  由于GRE把一个数据包封装到另一个数据包中,因此你可能会遇到以下情形:你发送的数据包超出你的接口所允许的大小。在通道接口上配置ip tcp adjust-mss 1436,就可以解决这个问题。

  虽然GRE不提供加密功能,但你可以使用tunnel key命令在通道的两端激活一个密钥,它就像一个没有加密的简单明文密码。

  因为GRE通道没有状态,那么可能出现这样的情况:通道的一端关闭,而另一端仍然开放。在解决这个问题,可以在通道的两端启动keepalive数据 包。这样设置后,通道的两端定期向另一端发送一个keepalive数据包。如果一端没有在指定的时间收到keepalive数据包,两端的通道就会关 闭。

----------------------------------------------------------

GRE Tunnel配置步骤说明

一、    基本配置
1、    设备名称
[Quidway] sysname shazikou
2、    SUPER密码设置
[shazikou]super password level 3 simple qdgs
3、    远程管理设置
[shazikou]user-interface vty 0 4
[shazikou-ui-vty0-4]authentication-mode password
[shazikou-ui-vty0-4]set authentication password simple qdgs
[shazikou-ui-vty0-4]quit
二、    端口配置
1、    广域口配置(WAN0)
[shazikou]int e1/0
[shazikou-Ethernet1/0] ip address 10.236.252.118 255.255.255.252
[shazikou-Ethernet1/0]quit
2、    局域口配置(无物理端口)
[shazikou]int e3/0
[shazikou-Ethernet3/0] ip address 192.168.25.65 255.255.255.224
[shazikou-Ethernet3/0]quit
三、    GRE Tunnel配置
[shazikou]interface tunnel 1 #创建虚拟端口,缺省协议为GRE
[shazikou -Tunnel1]ip address 192.168.204.10 255.255.255.252 #设置端口IP地址
[shazikou -Tunnel1]source 10.236.252.118 #设置Tunnel源端
[shazikou -Tunnel1]destination 10.231.252.38 #设置Tunnel目的端
[shazikou -Tunnel1]quit
四、    路由配置
1、    设置在网通内路由
[shazikou] ip route 10.231.252.38 255.255.255.255 10.249.252.117 # 采用网通网关
2、    设置工商网内路由
[shazikou] ip route 0.0.0.0 0.0.0.0 192.168.204.9 # 局端Tunnel端口地址

save
dis cur
  评论这张
 
阅读(1513)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018